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Tutor Setup Information 
 
 Copy the sample files folder, called Access 2010 Intermediate Course to the 

Documents folder on the PC. 
 At the end of the course, remove all files modified or created during the course, 

prior to re-running the course. 
 At the end of the course, reset all program and operating system defaults that 

may have been modified during the course, prior to re-running the course. 
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Sample files for this Course 
 

 During this course you will need to open samples files.   
 
These are stored under the Documents folder in a sub-folder called: 
 
Access 2010 Intermediate Course.   
 
If you create any new files, unless otherwise instructed, you should also save 
the files in this folder. 
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Queries 
 

What are queries? 
 Using a query is similar to filtering and sorting tables but much more powerful.  

Unlike filters, multiple criteria can be used in one or more fields to be highly 
specific about the information you wish to extract from a table. 
 

 Queries are used to extract and analyse data within one or more tables. 
 

 Queries can be saved, edited and reused.  They provide output for use by other 
database objects, such a forms and reports. 
 

 Queries are also capable of working with data across multiple tables. 
 

 Different queries are designed to perform different functions, for example an 
update query searches for and updates field information in one or more tables, 
whilst a delete query searches for and deletes records from one or more tables. 
 

 An update query is similar to the Find & Replace function found in most 
Microsoft applications, only more advanced.  For example, if telephone area 
codes change to accommodate an increasing population, an update query might 
be created to find all existing area codes affected by the change and at the same 
time, replace the old area code with a new area code. 
 
NOTE:  Update queries cannot create new records, only update existing records. 
 

 A select query is used to search for and display data according to the specified 
criteria.  This data can then be viewed as a table, in a form created specifically on 
the query or as a report. 
 

 A delete query is used when you need to remove entire records (rows) from a 
table. Delete queries, by default, remove all of the data in each field, along with 
the unique key field, (normally the primary key field) When the query is run, it 
removes the entire record (row) from the table. 
 
Before creating a delete query, you would create a select query first to ensure it 
returns the records that you want to delete.  This way you are able to test the 
query first, rather than inadvertently deleting the wrong records.  Only when the 
select query is tested and returns the correct results, would you convert the query 
to a delete query. 
 

 An append query, is used when you want to extract information (records) from 
one or more tables and append (add) it to one or more tables.  Normally the 
tables would reside in the same database however other database can also be 
used. 
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 A make table query retrieves data from one or more tables, and then loads the 
result set into a new table. That new table can reside in the database that you 
have open, or you can create it in another database. 
 

 As with all objects, Access provides a Wizard tool to help create different types of 
queries or blank queries that can be configured from scratch.  
 
NOTE: Tables do not have to be open or selected to create a query. 
 

Creating a query 
 Start the Access program. 
 Open a file called Queries. The database opens with two tables (Orders and 

Sales Employees) displayed in the Navigation Pane. 
 

 
 

 Click on the Create tab and from within the Macros & Code group click on the 
Query Wizard button. 
 

 
 

 The New Query dialog box is displayed. 
 

FOR USE AT THE LICENSED SITE(S) ONLY 
 2010 Cheltenham Courseware Pty. Ltd. www.cheltenhamcourseware.com.au 

SAMPLE



Access 2010 Intermediate  Page 10 

 
 

 With the Simple Query Wizard selected, click on the OK button.  The Simple 
Query Wizard dialog opens. 
 

 
 

 Use the down arrow in the upper part of the dialog box to select the table or 
query you intend working with, in this case select Table: Orders. 
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 In the lower part of the dialog box are two field selection boxes, Available Fields 
and Selected Fields. 
 

 
 

 Available Fields can be added to the Selected Fields box by first highlighting 
the field and then clicking on the right pointing arrow button. 
 

 
 
Or you could double click on a field within the Available Fields list. 
 
Alternatively, clicking on the button below adds all fields to the Selected Fields 
box. 

 
 
NOTE: When fields are displayed in the Selected Fields box, this button will 
remove all fields. 
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This button removes a single highlighted field. 

 
 

 Add the following fields:  
 
First Name 
Last Name 
Category 
Product Name 
Quantity 
Order Date. 
 

 
 

 Click on the Next button. 
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 Click on the Next button. 
 

 
 

 At this point you can accept the default name provided by Access or type your 
own.  Highlight the Query Name and type in Customer Orders, as illustrated. 
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 Click on the Finish button. The Customer Orders query displays the result in 
table form. 
 

 
 

 The new query can be seen as a new object in the Navigation Pane. 
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 Currently all this query has done is to display information from the Orders table 
using only the fields chosen as you worked through the wizard. 
 
NOTE: By default, Access has already saved the query using the name provided 
during the wizard process. 
 

Adding (and removing) criteria to a query 
 To utilise the power of a query and locate specific records, criteria must be 

entered to give the query something to work with. 
 
For example, if there is a need to locate orders placed between certain dates, we 
would use the AND operator with the following type of criteria entered into the 
date field of the query. 
 
>=01/01/2006 AND <=01/06/2006     
 
Using the OR operator you could enter the following criteria into the date field. 
 
22/01/2006 OR 9/04/2006 
 
This criteria would locate records with either of those two dates. 
 
The NOT operator could be used to exclude records with certain dates from the 
query results.  For example:  
 
NOT 22/01/2006 
 
This criteria would exclude all records dated 22/01/2006 from the query results. 
 
TIP:  Operators used to create criteria in queries are the same operators used to 
create validation rules. 
 

FOR USE AT THE LICENSED SITE(S) ONLY 
 2010 Cheltenham Courseware Pty. Ltd. www.cheltenhamcourseware.com.au 

SAMPLE



Access 2010 Intermediate  Page 16 

 
 

 To add criteria to a query, the query must first be in Design View. Click on the 
Home tab.  Click on the down arrow under the View button to switch to Design 
View. 
 

 
 

 Your screen will now look like this. 
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 Similar to other objects when in Design View, queries have their own specific 
ribbon, functions and tools. 
 

 
 
NOTE:  Although this is currently a Select query, this query can be modified at 
any stage to become a different type of query and therefore perform a different 
function. 
 

 
 

 When working with existing queries, the table field list, located in the Query 
Design window, is similar to that used when creating relationships between 
tables.  The underlying table can be identified by the name at the top of the list, in 
this case Orders. 
 

  
 
NOTE: One difference with this table field list is the * symbol above the Primary 
Key.  When used, the * represents All fields in the table and is used to save time. 
 

 The Query Design Grid is where selected fields from one or more tables are 
added, criteria entered, the sort order set and fields set to display or not when the 
query is run. 
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NOTE: Fields can be included in the query design grid for criteria (record search) 
purposes only and they do not have to be displayed when the query is run. 
 

 Place the mouse pointer in the Criteria row under the Order Date field in the 
query design grid and type the following. 
 
>=1/06/2006 AND <=31/05/2007 
 

 
 

 Press the Enter key or use the keyboard cursor key to move to another cell in the 
grid. 
 

 Notice how the criteria entered changes.  Access places hash symbols either 
side of the dates to signify this value as a date. 
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NOTE: You may have to widen the column to see this clearly. 
 

 
 
NOTE: Don’t do this now, but if you wanted to remove this criteria, you would 
simply select it in Design View and then press the Del key to delete it. 
 

Running a query 
 When all the necessary fields, criteria, sort parameters, etc., have been entered 

into a query and it is ready to be tested or used, you will need to ‘run’ the query. 
 

 As an example, when you run a select query, you are giving the query a 
command to look at its parameters, go and search the table or tables for records 
matching the criteria and produce a list of those records. 
 

 Click on the Design tab and from within the Results group click on the Run 
button. 
 

 
 

 The results of the query are displayed in table form, as illustrated. 
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 Look at the data within the Order Date column and you should see that all the 
dates displayed are within the range specified by the query criteria. 
 

 In the Navigation Pane, click once on the Customer Orders query to select it. 
 

 
 

 Click on the Design View button to return to Design View. 
 

 
 

 Next we want to narrow down the search to purchases made for products which 
fall under the Dried Fruit & Nuts and Grains categories, between the date 
criteria previously set. 
 

 Place the mouse pointer into the Criteria row of the query design grid in the 
Category field.  Type in the following. 
 
Dried Fruit & Nuts.   
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 Use the keyboard down arrow pointer key or mouse to move down to the row 
below (the ‘or’ row) in the same field (Category). 
 

 
 

 Type in the following and press the Enter key. 
 
Grains 
 

 
 
NOTE: This time Access encloses the text with “Speech” marks to set the data 
type to search for as text. 
 

 When run, the query will now search for any records between the date range 
specified which contain either Dried Fruit & Nuts or Grains. 
 

 Click on the Design tab and from within the Results group click on the Run 
button. 
 

 
 

 When the results are displayed however they are not what we might have 
expected.  There are no records listing Dried Fruit & Nuts. 
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 It is possible that none of the sales of Dried Fruit & Nuts took place between the 
dates specified but this is unlikely.  Either way, it is worth checking the query 
design to make sure the criteria is correct. 
 
TIP: The easiest way to check the results is to take a look at the table or tables 
the query is working with.  If records matching the criteria are available in the 
table but not the query, there must be an issue with the query design. 
 

Editing criteria in a query 
 Switch back to Design View (using the View button). 

 

 
 
 

 As we know the data range works, having run the query prior to adding the 
Category criteria, the problem must be elsewhere.  Look at the criteria in the 
Category field. 
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 When you entered the criteria and moved to the next row, Access added 
“speech” marks.  The criteria went from Dried Fruit & Nuts to "Dried Fruit" & 
"Nuts". 
 

 Despite all good intentions, Access does not always interpret entries in the way 
there were intended.  Access has seen the & between Dried Fruit and Nuts and 
interpreted this to be two statements;  
 
1) Dried Fruit 
2) Nuts. 
 

 As no such entries exist in the table, nothing was displayed. 
 

 Place the pointer into the Criteria row of the Category field and remove the two 
“speech” marks either side of the & symbol.  
 
The result should be "Dried Fruit & Nuts". 
 

 
   

 Press Enter to commit the changes. 
 Click on the Design tab and from within the Results group click on the Run 

button. 
 

 
 

 The results are displayed and this time includes records which contain the 
category Dried Fruit & Nuts according to the criteria set. 
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Saving a query 
 When first created using the Access wizard, a query is saved automatically.  If 

the query is then modified at a later stage or you create a blank query, you will 
need to save using the Save button.  
 

 
 

 If you make changes to a query and then run the query, then when you exit the 
query without saving, you will be prompted to save the query. 
 

 
 

 Click on the Yes button to save any changes, otherwise they will be lost and you 
will have to start afresh. 

 Right click on the Customers Orders query tab. 
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 This will display a popup menu.  Select the Close command. If prompted, click on 
the Yes button to save the query. 
 

  
 

Creating a two table query and sorting the results 
 More often than not, the information in a database will be split across multiple 

tables.  For a query to work with multiple tables, a relationship between the tables 
must be established. 
 

 Continuing with the Queries database and the Customer Orders query, the next 
objective is to search for records matching a given criteria, using both the Orders 
and Sales Employees table. 
 

 Click on the Create tab and from within the Macros & Code group, click on the 
Query Design button. 
 

 
 

 The Query Design window is displayed.  
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 The Show Table dialog box is also displayed, similar to the one used to add 
tables when creating table relationships. 
 

 
 

 Click on the Add button to add the Orders table. 
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 Select the Sales Employees table and click on the Add button again. 
 

 
 
TIP: Double clicking on both table names quickly adds them to the query design 
window. 
 

 When both tables have been added to the query design window, click on the 
Close button to close the Show Table dialog box. 
 
NOTE: If you inadvertently add a table twice to the query design window, with the 
pointer in the name area at the top of the additional table, (normally identified by 
the Original Table name with a _1 after the name), click using the right mouse 
button and from the shortcut menu, select Remove.  See next image.  
 

 When the Show Table dialog box is closed, the design window should be left 
with two linked tables. 
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 The purpose of this query is to check the sales performance of staff.  The Sales 
Employees table contains the names of each of the sales teams and other staff 
information.  The Orders table contains information about products sold, 
quantities, dates, etc.   
 

 A relationship between the two tables has already been established with the 
Employee Number (Primary key) field in the Sales Employees table linked to 
the Employees ID (Foreign key) field in the Orders table. 
 

 Employee names are not listed in the Orders table.  To have the query display 
the names of staff against the orders they have processed, a query will have to 
include fields from both tables. 
 

 In the Orders table, click once to select the Category field.  Now hold down the 
Ctrl key and click once on each of the following fields. 
 
NOTE: You may need to scroll down the list to see all these items. 
 
Product Name 
Quantity 
Order Date. 
 

 Release the Ctrl key and the four fields should now be highlighted within the 
Orders table. 
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 In one movement, place the pointer over one of the highlighted fields, click and 
drag to the design grid below.  When the pointer is in the grid, release the mouse 
button.  The fields are added to the design grid and are ordered from left to right 
as they would be in the table. 
 

 
 

 Next click to select the Employee Name field in the Sales Employee table. 
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 Click and drag the Employee Name field down and to the next blank column to 
the right of the Order Date field. 

 With the pointer correctly positioned, release the mouse button to add the field. 
 

 
 
NOTE: The table row of the query design grid displays the names of the tables 
used in this query. 
 

 Click on the Save button. 
 

 
 

 When prompted to name the query, type in Staff Sales Figures. 
 

 
 

 Click on the OK button to name and save the query. 
 Click on the Design tab and within the Results group click on the Run button. 

 

 
 

 The query displays a table containing a list of all the sales staff and the orders 
placed with each member of staff.  At this time the table is arranged in order of 
Employee ID, the primary key field, even though this field was not included in the 
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query design. 
 

 
 

 Switch to Design View by clicking on the View button. 
 

 
 

 Move the mouse pointer to just above the Employee Name field name (within the 
lower section of the screen) where there is a thin grey line and until the pointer 
changes to a down arrow shape. 
 

 With the down arrow shape as the pointer, click to highlight the Employee 
Name field. 
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 Move the pointer once more to just above the Employee Name field name 
where there is a thin line and until the pointer this time changes to an arrow 
shape. 
 

 
 

 In one movement, click and drag the field to the left of the Category field, then 
release the mouse button. 
 
NOTE: As always, Access provides a thick black guideline to highlight the current 
position of the moving field before release.  The Employee Name field should 
now be on the left side of the query design grid. 
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 Using the pointer, click in the Sort row under the Sales Employees field.  Then 
click on the down arrow displayed in this cell. 
 

 
 

 Select Ascending from the drop down option box.  When run, this query will 
display the results in alphabetical order of Employee Names, rather than order of 
Employee ID. 
 

 Click into the Criteria row of the Category field, type in the following word and 
then press the Enter key.   
 
Beverages 
 
When run, this query will return only records which match Beverages in the 
Category field. 
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 Click on the tick box above the criteria you just entered in the Category field.  
This will remove the tick.  Although the Category field is used by the query to 
specify search criteria, the field does not have to be displayed in the final results. 
 

 
 

 Click on the File tab and click on the Save Object As button. 
 

 
 

 In the Save As dialog box, replace the default name with: 
 
 Staff Sales Figures – Beverages 
 

 
 

 Click on the OK button.  
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 Click on the Home tab and the Navigation Pane displays the newly saved query. 
 

 
 

 The query tab also changes to display the new name, as illustrated 
 

 
 

 Click on the Design tab and from within the Results group click on the Run 
button.  
 

 
 

 The results of the modified query are displayed.  Only records matching the 
search criteria Beverages in the Category field are displayed and the Category 
field is hidden. 
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 Save your changes and close the Access program. 
 

Refining your query 
 Start the Access program. 
 Open a database called Refining a query. 

 

 
 

 Double click on the Staff Sales Figures – Beverages query.  
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 What if there was a bonus incentive for staff who sold more than 40 items of any 
Sauce products since 01/01/2007.  Also Nancy Freehafer has left the company; 
therefore we want to exclude her from the search.   
 

 You can use and modify an existing query; however the query should be given a 
new name and saved before changes go ahead. 
 

 Click on the File tab and click on the Save Object As button.  
 

 
 

 In the Save As dialog box, replace the default name with:  
 
Staff Incentive – Sauce Sales. 
 

 
 

 Click on the OK button.  
 Click on the Home tab and the Navigation Pane displays the newly saved query. 
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 The query tab also changes to display the new name. 
 

 
 

 Click on the Home tab, click on the View button and then click on Design View. 
 

 
 

 Move the pointer to just above the Category field name where there is a thin grey 
line and until the pointer changes to a down arrow shape.  With the down arrow 
shape as the pointer, click to highlight the Category field. 
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 With the field highlighted, press the Delete key on the keyboard to delete the field 
from the grid. 
 

 
 

 Click within the Criteria row of the Employee Name field and type:  
 
<>Nancy Freehafer  
 
Then press the Enter key. 
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 Click into the Criteria row of the Product Name field and type:  
 
Like *Sauce*  
 
Then press the Enter key. 
 

 
 
NOTE: Wildcards such as the * can be used to signify, in this case for example, 
that the word Sauce can appear anywhere in the Product Name description. 
 

 Click into the Criteria row of the Quantity field and type the following and press 
the Enter key. 
 
>40 
 

 
 

 Click into the Criteria row of the Order Date field and type 
 
>=01/01/2007  
 
and press the Enter key.  
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 Click on the Save button in the Quick Access toolbar to save the changes to the 
new query. 
 

 
 

 Click on the Design tab and from within the Results group click on the Run 
button.  
 

 
 

 Your screen will now look like this. 
 

 
 

 Right click on the Staff Incentive – Sauce Sales query tab and from the popup 
menu displayed select the Close command. 
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 Close the Access program. 
 

What are Wildcards? 
 Wildcards are special characters that you can use within a query to specify or 

exclude certain characters.  If you examine the charts below, they should become 
more understandable.   
 

Wildcard Function Examples 

% Matches multiple characters within a 
string at the start or finish of a character 
string. 

wh% would find: 
when 
what 
which 
 
It would not find: 
awhile 
watch 
water 
 

_ Matches a  single alphabetic character 
within a string 

B_ll would find: 
bull 
ball 
bell 
 
It would not find: 
Bail 
 

[ ] Matches any single character defined 
within the brackets. 

B[ae]ll would find: 
ball  
bell 
 
It would not find: 
bill 
 

^ Matches any character not defined within 
the brackets. 

b[^ae]ll would find: 
bill  

FOR USE AT THE LICENSED SITE(S) ONLY 
 2010 Cheltenham Courseware Pty. Ltd. www.cheltenhamcourseware.com.au 

SAMPLE



Access 2010 Intermediate  Page 43 

bull 
 
It would not find: 
ball  
bell 
 

- Matches any one of a range of characters 
defined within the brackets, which must 
be defined in ascending order, i.e. A to Z 
and not Z to A. 

z[a-c]z would find: 
xaz 
xbz 
xcz 

 

Deleting a query 
 In the Navigation Pane, click once to highlight the Staff Sales Figures query. 

 

 
 

 Press the Delete key on the keyboard.  Access displays a warning dialog box. 
 

 
 

 Click on the Yes button to continue and delete the query.  The screen will now 
look like this 
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 Close Access. 
 

Hiding and un-hiding fields within a query 
 Open the Access program. 
 Open a database called Hiding.  Your screen will look like this. 

 

 
 

 Double click on the query called Customers Query and you will see the 
following. 
 

 
 

 To hide the City field, we need to select the City column.  To select this column 
click at the top of the City column, as illustrated below. 
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 Right click over the top cell containing the word City and from the popup menu 
displayed select the Hide Fields command. 
 

 
 

 The screen will change as illustrated below.  The City column has been hidden. 
 

 
 

 To unhide the hidden column you need to select the columns either side of the 
hidden column, as illustrated below.  Now when you right click over the selected 
columns you will now see the Unhide Columns command. 
   

 
 

 Clicking on this command will display the Unhide Columns dialog box. 
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 Click on the column that is hidden, in this case City and then click on the Close 
button.  The column will then become visible, as illustrated below. 
 

 
 

 Save your changes and close the database. 
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Reports 
 

What are reports? 
 In Access, a report is a summary generated from information in a table or query.  

Access provides you with a number of tools that help you to quickly build reports 
that present the data in an organised, meaningful and easy-to-read layout.  
These reports can then be printed. 

 You can use the commands on the Create tab to create a simple report with a 
single click, use the Report Wizard to create a more complicated report or create 
a report from scratch by adding all the data and formatting elements. 
 

 
 

 Whichever method you choose, you will probably need to make at a few changes 
to the design, for example, adjusting column positions and widths to fine tune the 
final output of the report (how it displays on the screen or printed). 
 

Creating a simple report 
 Reports are based on information in tables or queries.  If the report is to be based 

on information contained in more than one table, a relationship must exist, 
however it is far more likely that a query has already been created to produce the 
information required for the report. 

 Click on the File tab and click on Open and open a file called Reports contained 
within your samples folder. 

 The database opens with two tables (Orders and Sales Employees) and two 
queries (Beverage Sales and Customer Orders) displayed in the Navigation 
Pane. 
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 In the Navigation Pane, click once on the Beverage Sales query to highlight the 
query, but do not open it. 
 

 
 

 Click on the Create tab and from within the Reports group, click on the Report 
button.  
 

 
 

 A report based on the Beverage Sales query is displayed on your screen. 
 

 
 

 The simple report is displayed for any modifications that may be required.  Editing 
and modifying a report is similar to editing a form.  The title, field text labels and 
logo images can all be resized, moved or deleted as necessary.  Even the style 
can be altered at the click of a button using the pre-set styles in the AutoFormat 
group. 
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 Simple reports are not saved until you either click on the Save button in the 
Quick Access toolbar or attempt to close the report, at which point Access will 
prompt you to save the report. 
 

 
 

 Click on the Save button.   
 

 
 

 The Save As dialog box is displayed. 
 

 
 

 Click on the OK button. The new report is displayed in the Navigation Pane. 
 

 
 

 Click on the Close button towards the top right of the report window, to close the 
report. 
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Using the Report Wizard 
 Click on the Create tab and from within the Reports group click on the Report 

Wizard button.  
 

 
 

 First fields from one or more table must be selected.  Click on the 
Tables/Queries dropdown list and select the Table: Orders. 
 

 
 

 The dialog box will now look like this. 
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 From the Available Fields, double click each of the follow fields:  
 
Category 
Product Name 
Unit Qty 
Quantity 
 

 
 

 Click on the Tables/Queries drop down list and select the Table: Sales 
Employees. 
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 The dialog box will now look like this. 
 

 
 

 From the Available Fields, double click on the Employee Name field. 
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NOTE: The report will now use information from the Orders table and also from 
the Sales Employees table. 
 

 Click on the Next button. 
 

 
 

 Leave the default by Orders selected. 
 
NOTE: When the report is complete, because by Orders is selected, information 
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will be grouped according to a field or fields in the Orders table. This field or 
fields will be selected in the next section of the wizard.  For example, the ideal 
field to use to group information in the report is the Category field.  If by Sales 
Employees was selected instead, the employees names would take priority in 
the report and products would be grouped under each employee. 
 

 Click on the Next button. 
 

 
 
NOTE: When the report is complete, you will see that the report is broken down 
into Categories first, then Products, Quantities, Dates and finally Employees. 
 

 Select Category, and then click on the right arrowed button to add the grouping 
level. 
 

 
 

 The dialog box will now look like this. 
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 Click on the Next button. 
 

 
 

 In the Sort Order dialog box, click on the drop down arrow and select Product 
Name. 
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 The dialog box will look like this. 
 

 
 
NOTE: By selecting a field, in this case the Product Name field, when the report 
is complete, information will be organised in Ascending order of Product Name, 
within each category. 
 

 Click on the Next button.  Leave the Layout as the default setting. 
 

FOR USE AT THE LICENSED SITE(S) ONLY 
 2010 Cheltenham Courseware Pty. Ltd. www.cheltenhamcourseware.com.au 

SAMPLE



Access 2010 Intermediate  Page 57 

 
 
NOTE: The three Layout options control how the report will be laid out when 
finished.  Depending upon the number of fields included in a report, consideration 
should be given to the report Orientation.  If there are too many fields for a 
single page width, select Landscape, otherwise (in this case) Portrait will be 
sufficient.  Orientation can be changed at any stage before printing. 
 

 Click on the Next button.   
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 Access has given the report the name Orders.  Click on the Finish button to 
accept the name and complete the wizard.  The report is now displayed in Print 
Preview view.  Take a while to see what has been produced. 
 

 
 

 Click on the Close Print Preview button. 
 

 
 

 The report will be displayed in Design View. 
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Modifying the layout of a report 
 Click on the Layout View button, displayed at the bottom-right of the screen. 

 

 
 

 The report will be displayed as illustrated below. 
 

 
 

Widening a report column 
 We need to widen the Category column as some of the items within the column 

are wider than the column.  To do this click on the Category field name to first 
select the column.   
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 Move the pointer to the dotted line running down the right side of the Category 
column. When the pointer changes to a horizontal line with arrows on each end, 
click and drag the line to the right, increasing the width of the column until it is 
wide enough to display all categories. 
 

 
 

 The columns will now look like this 
 

 
 

Modifying the report title 
 Click once on the report title (Orders). 

 

 
 

 Double click to highlight and select the word Orders. 
 

 
 

 Type in the following to replace the existing label and press the Enter key to 
complete the modification. 
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Product Orders by Category  
 

 
 

 Position the pointer over the report title box again, this time until the pointer 
changes to crosshair. 
 

 
 

 Click and drag the report title box to the right as illustrated below. 
 

 
 
 

Adding a logo to a report 
 Click on the Design tab and from within the Header / Footer group click on the 

Logo button. 
 

 
 

 The Insert Picture dialog window is displayed.   
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 Double click on the Images folder to display your sample images. 
 

 
 

 Double click on the Beverage Logo file to add the image to the report. 
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 The new image is too small.  Position the pointer over the right edge of the logo 
box until the pointer displays an arrow. 
 

 
 

 Click and drag the right side of the box to the right (expand size).  Expand the 
box a small amount and let go of the mouse button. 
 

 As the box expands, the image increases in size.  Keep expanding the box until 
the image fits in the box from top to bottom. 
 
 

 With the logo resized, position the pointer over the report title box again, this time 
until the pointer changes to crosshair. 
 

 
 

 Click and drag the title box to the left until there is a small gap between the title 
and the new logo, as illustrated below. 
 

 
 

Formatting a form using themes 
 Click on the Design tab and within the Themes group, click on the Themes 

button. 
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 A drop down theme menu will be displayed.  As you move the mouse pointer 
over each theme the format will preview the theme formatting.   

 
 

 Click on any one of the themes and the theme will be applied to the form. 
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Modifying field names within a report 
 Click on the Product Name field title.   

 

 
 

 Double click on the word ‘Name’ and press the Del key.  
 

 
 

 Press the Enter key.  The column will now be called Product, rather than 
Product Name. 
 

 
 

Inserting and formatting the date & time 
 Within the Design tab you will see the Header / Footer group.  Click on the Date 

and Time button.  
 

 
 

 The Date and Time dialog box is displayed. 
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 Click on the OK button. 
 

 
 

 The date and time are inserted into the top (header) section of the report to the 
right of the report title but are very hard to read as they are displayed using a 
dark coloured font, on a dark background. 
 
NOTE: The date and time are inserted separately; therefore each will require 
individual modification. 
 

 Click once on the date to select it.   
 

 
 

 Within the Home tab you will see the Text Formatting group. 
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 Use the normal font formatting techniques to make the date display using bold.  
Also increase the font size and maybe use a different font type. 
 

 Repeat the steps to modify the time. 
 

Adding existing fields to a report 
 Click on the Design tab, and within the Tools group, click on the Add Existing 

Fields button. 
 

 
 

 The Field List opens (to the right of your form) and displays the tables within the 
database and the available fields. 
 

 
 

 Click within the Employee Name column. 
 In the Fields List, double click on the Position field to add it to the report. 
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 The new field will be displayed as illustrated. 
 

 
 
NOTE: When adding fields to an existing report, the new field is added to the 
right of whichever field (column) is selected.  For example, if the Employee 
Name was selected, the Position field would have been inserted to the right of 
Employee Name. 
 

 Click on the Close button to close the Field List. 
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Resizing reports for printing 
 With the field list closed and the Unit Qty field added to the report, it is possible 

that you may to see a dotted line running down and through the field displayed at 
the extreme left of the report. 
 

  
 
NOTE: This line represents print guidelines (margins) and in this case, indicates 
that part of the field will fall outside of the printing area.  If printed, the report 
would be two pages wide, instead of one. 
 

 The fields need to be resized to fit within the dotted line. 
 Click in each of the field name at the top of each column and one by one, use the 

normal drag and drop techniques to resize each column so that you will be able 
to print on a single page. 
 

 Save and changes you have made and close the Access program. 
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Totals 
 Start Access. 
 Open a database called Totals. 
 Double click on a report called Orders. 

 

 
 

 The screen will look like this. 
 

 
 

 The report is to include the total number of items sold and the number of sales in 
each category. 

 Click on the Product field name. 
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 Click on the Totals button, located under the Design tab within the Grouping & 
Tools group  
 

 
 

 From the drop down list displayed, select Count Records. 
 

. 
 

 Click on the Quantity field name. 
 

 Click on the Totals button, located under the Design tab within the Grouping & 
Tools group  
 

  
 

 From the list displayed select the Sum command. 
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. 
 

 Below each group (category) a value is displayed in both the Product Name and 
Quantity columns. 
 

 
 

 On the last page of the report, grand totals of all groups are also displayed. 
 

 
 
NOTE: The format of the totals can be modified by selecting them first, then from 
the Font group in the Home ribbon tab, selecting a different size, font or simply 
making them bold. 
 

Closing a report 
 Right click on the Orders report tab.  Select the Close command from the list 

displayed, to close the report. 
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Deleting a report 
 In the Navigation Pane, click once on the Beverage Sales report to highlight. 

 

 
 

 Press the Delete key to delete the report. Access prompts for confirmation. 
 

 
 

 Click on the Yes button. The report is deleted from the database. 
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Exporting 
 

What does exporting data mean? 
 When you save data you save it to disk in the same file format used by the 

application, in this case Microsoft Access.  Exporting data means saving the data 
in a different format.  For instance we could save our database in a spread sheet 
format (such as Microsoft Excel format), or as text or in XML format. 
 
It is important to note that you cannot use the Access Save As command to save 
the database in an alternative format such as an Excel workbook, text file or XML 
file.  You need to export the file. 
 

What is a spread sheet format? 
 The file is actually stored as a workbook and each workbook can contain many 

worksheets (which contains the tables of data).  A typically example is Microsoft 
Excel. 
 

What is text only and CSV format? 
 As the name implies, if you export a database in text only format, then only text 

will be saved.  You will lose all formatting and other non-text information.   
 
A common text format is called a CSV format.  This is short for Comma 
Separated Vales.  A CSV file maintains the record and field database structure by 
inserting a comma after each field within the file.  You could then import the CSV 
formatted files into a database or spread sheet and it would be able to delimit, i.e. 
separate, the rows and columns to correctly display the basic data.  CSV files will 
not retain any formatting or other non-text related information. 
 

What is a PDF file? 
 The Adobe Acrobat PDF file format is useful because if you save your objects as 

PDF files these can be viewed by other people who may not have access to the 
Access program.  The PDF files can also be displayed within web sites or 
attached to emails and send to colleges. 

 The Adobe Acrobat Reader program is required to view PDF formatted files and 
is available as a free download from the Adobe web site. 
 

What is an XML file? 
 XML is short for ‘Extensible Mark-up Language’.  It is a general-purpose mark-up 

language that allows you to share data created by different hardware and 
software via the Internet.   

 

FOR USE AT THE LICENSED SITE(S) ONLY 
 2010 Cheltenham Courseware Pty. Ltd. www.cheltenhamcourseware.com.au 

SAMPLE



Access 2010 Intermediate  Page 75 

Exporting a table as an Excel file 
 Start the Access program. 
 Open a database called Exporting. 
 Select but do not open the table called Next Weeks Courses. 

 

 
 

 Click on the External Data tab and from within the Export group, click on the 
Excel button. 
 

 
 

 You will see the following dialog box. 
 

 
 

 Click on the Browse button. 
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 You should see the Access 2010 Intermediate Course folder displayed within 
the right section of the dialog box.  Double click on the Access 2010 
Intermediate Course folder to change to that folder.  The dialog box will now 
look like this. 
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 Enter a file name such as Excel Version Next Weeks Courses. 
 Click on the Save button and you will see the following dialog box displayed. 

 

 
 

 Click on the OK button to save the database table in an Excel file format.  You 
will see a final dialog box displayed, click on the Close button to close the dialog 
box. 
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 Don’t actually do this now, but if you used the Windows Explorer program to 
view the contents of your Access 2010 Intermediate Course folder you would 
see the new Excel file listed as illustrated. 
 

 
 
 

 Close the Access program. 
 

Exporting a table as a text file (keeping data format & layout) 
 Start the Access program. 
 Open a database called Exporting. 
 Select but do not open the table called Next Weeks Courses. 

 

 
 

 Click on the External Data tab and from within the Export group, click on the 
Text File button. 
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 You will see the following dialog box. 
 

 
 

 Click on the Browse button. 
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 You should see the Access 2010 Intermediate Course folder displayed within 
the right section of the dialog box.  Double click on the Access 2010 
Intermediate Course folder to change to that folder.  The dialog box will now 
look like this. 
 

 
 

 Enter a file name such as Text File Version Next Weeks Courses. 
 Click on the Save button to export the table to a text file.  You will see the 

following dialog box. 
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 Select the first option which will keep the column structure intact. 
 

 
 

 Click on the OK button and you will see the following dialog box displayed. 
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 Use the default encoding option and click on the OK button.  The following dialog 
box will be displayed. 
 

 
 

 Click on the Close button. 
 

 Don’t actually do this now, but if you used the Windows Explorer program to 
view the contents of your Access 2010 Intermediate Course folder you would 
see the new Excel file listed as illustrated. 
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 If you were to open the file to a text only editing program, such as Notepad, the 
data would look like this. 
 

 
 
NOTE: This format is NOT what many programs will expect when importing data 
from Access.  Normally you would save to a text file in CSV format. 
 

 Close the Access program. 
 

Exporting a table as a text CSV formatted file  
 Start the Access program. 
 Open a database called Exporting. 
 Select but do not open the table called Next Weeks Courses. 
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 Click on the External Data tab and from within the Export group, click on the 
Text File button. 
 

 
 

 You will see the following dialog box. 
 

 
 

 Do not select one of the three export options, but simply click on the OK button to 
continue.  You will see the following dialog box displayed.  Make sure that the 
Delimited option is selected. 
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 Click on the Next button.  You will see a dialog box allowing you to specify 
delimitation type.  Make sure that the Comma option is selected. 
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 Click on the Next button. The following dialog box will be displayed. 
 

 
 

 You will notice that the default file name extension is .TXT.   

 
 

 You can change this to CSV. 
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 You can also manually modify the save location, as illustrated, to save the file in 
the same folder as your other sample files. 
 

 
 

 Finally you could change the actual file name from Next Week Courses to CSV 
Formatted Courses.  The dialog box should now look like this. 
 

 
 

 Click on the Finish button and you will see the following dialog box displayed. 
 

 
 

 Click on the Close button. 
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 Don’t actually do this now, but if you used the Windows Explorer program to 
view the contents of your Access 2010 Intermediate Course folder you would 
see the new CSV file listed as illustrated. 
 

 
 

 Close the Access program. 
 

Exporting a table as a PDF formatted file 
 Start the Access program. 
 Open a database called Exporting. 
 Select but do not open the table called Next Weeks Courses. 

 

 
 

 Click on the External Data tab and from within the Export group, click on the 
PDF or XPS button. 
 

 
 

 This will display the following window.  
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 Change to the Access 2010 Intermediate Course folder, by double clicking on 
the folder. 

 In the Save as Type section make sure that PDF is selected. 
 Click on the Publish button.  If you have the Adobe PDF Reader program 

installed you may see the file displayed, as illustrated. 
 

 
 

 Close the PDF Reader program. 
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 Close the Export – PDF window by clicking on the Close button. 
 

 
 

 Don’t actually do this now, but if you used the Windows Explorer program to 
view the contents of your Access 2010 Intermediate Course folder you would 
see the new Adobe PDF file listed as illustrated. 
 

 
 

 Close the Access program. 
 

Exporting a table as an XML formatted file 
 Start the Access program. 
 Open a database called Exporting. 
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 Select but do not open the table called Next Weeks Courses. 
 

 
 

 Click on the External Data tab and from within the Export group, click on the 
XML File button. 
 

 
 

 You will see the following dialog box. 
 

 
 

 Click on the Browse button. 
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 You should see the Access 2010 Intermediate Course folder displayed within 
the right section of the dialog box.  Double click on the Access 2010 
Intermediate Course folder to change to that folder.  The dialog box will now 
look like this. 
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 Click on the Save button and you will see the following dialog box displayed. 
 

 
 

 Click on the OK button and you will see the following dialog box. 
 

 
 

 Click on the OK button.  You will see a final dialog box displayed, click on the 
Close button to close the dialog box. 
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 Click on the Close button. 
 

 Don’t actually do this now, but if you used the Windows Explorer program to 
view the contents of your Access 2010 Intermediate Course folder you would 
see the new XML file listed as illustrated. 
 

 
 
 

 Close the Access program. 
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Printing 
 

Considerations before printing 
 Tables, queries and reports all use a grid layout which includes columns and 

rows.  It is therefore important to consider the number and width of columns when 
it comes to printing. 

 If the number of fields can be kept to a single sheet (width), either portrait or 
landscape, it will save on the number of pages you need to print. 

 Although information can be printed directly from a table, consider using a query 
to extract only the fields and records that are actually required. 
 

Print previewing 
 Print Preview view shows how the report, table, etc. will look when printed.  This 

includes the layout of columns (fields) on the page(s), how many pages are 
required to print the information, the margin sizes, titles, page numbers, etc. 
 

 Before you can preview your print job, the object must either be selected within 
the Navigation Pane or open in the object window.  To print only selected records 
from a table, the table would have to be open first to select the records. 
 

 Open Access and open a file called Printing.  You will see the following. 
 

 
 

 Double click on the Orders report to open it, as illustrated. 
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 To use Print Preview, click on the File tab and from the drop down list displayed, 
click on the Print button.  Click on the Print Preview button. 
 

 
 

 The screen will now look like this. 
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 A previously unseen Print Preview ribbon appears, offering you the most 
common tools required to adjust and modify the layout of you object to achieve 
the best printing results. 
 

 
 

 A Page Navigation Bar, similar to the Record Navigation Bar used in tables, 
queries and forms can be seen at the bottom-left of the object window. 
 

 
 

 When you first run Print Preview, the document displayed may appear 
unreadable.  By placing the pointer over the document, the pointer changes to a 
magnifying glass.  One click will zoom in to make the document readable and 
another click zooms out again. 
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 The Zoom group also offers further tools to enhance the focus and view of the 
document when working within Print Preview. 
 

 
 

 The Zoom button offers zoom pre-sets in percentages and the three pages per 
view options offer the chance to preview multiple pages at once.  This is useful 
when you are more interested in the layout than the actual data content. 
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 In the Page Layout group the buttons control page size and page orientation, as 
well as margin sizes. 
 

 
 

 Clicking on the Page Size button displays a dialog box listing common 
International pages sizes. 
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 By default, Access previews pages in portrait orientation.  If you are unsure which 
orientation you are viewing, look at the Layout group in the ribbon.  Whichever of 
the two orientation buttons is active, i.e. brightly shaded, indicates the current 
page orientation. 
 

 When the Portrait button is selected and active, the page orientation is Portrait  
 

 
 
 

 The page will look like this. 
 

 
 

 When the Landscape button is selected and active. The page orientation is 
Landscape.  The screen will look like this. 
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 Close the Access program and save any changes you may have made. 
 

Which orientation, portrait or landscape? 
 When printing portrait pages, the advantage, assuming the report is only one 

page wide, is that more records can be printed per page, resulting in less pages 
being printed. 
 
Landscape orientation on the other hand is useful when the table, report, etc. has 
more fields (columns) than a portrait page can accommodate. 
 
NOTE: When columns overflow the first page, a second page is used, in effect 
creating a two page wide printout.  If those who the printouts are intended for are 
to make good use of the printouts, reports, etc., it is recommended that the 
printouts be kept to a manageable size. 
 

Adjusting layout in Print Preview 
 Start the Access program. 
 Open the database called Printing. 
 Double click on Orders in the Navigation Pane to open the Orders table. 
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 Click on the File tab and then click on the Print button.  Click on the Print 
Preview button. 
 

 
 
 

 The displayed is illustrated below. 
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 The Page Navigation Bar is displayed below the table preview. 
 

 
 

 Click on the right arrowed button once.  
 

  
 
Make a note of the fields in page 2 and then click on the right arrowed button 
again and note which fields are in page 3. 
 

 
 
Currently, a print of this table would be 3 pages wide, multiplied by the number of 
pages require to print all or selected records. 
 

 Click on the Landscape button. 
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 In Landscape orientation, the printout only requires two pages (width), again 
multiplied by the number of pages require to print all or selected records. 
 
NOTE: You use the same page orientation techniques for tables, forms, query 
output and reports. 
 

Setting margins 
 Next, click on the Margins button within the Ribbon. 

 

 
 

 This will display some pre-set options. 
 

 
 

 Select the Narrow option from the list.  More records are visible in the preview 
and this could result in fewer pages being printed. 
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NOTE: Another option to help further reduce the number of pages required to 
print a table, is to resize and reduce column widths or even hide columns not 
necessary to the printout. 
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END OF THE EVALUATION PREVIEW 
 
This sample is approximately half of the complete course and is provided for 
evaluation purposes only.   
 
To purchase the rights to the editable version, supplied in Microsoft Word,  
please visit our web site at: 
 

http://www.cctglobal.com 
 
 

 
 

 Customisable Courseware. 

 No Annual Renewal Fees. 

 Unlimited Number of Users. 

 Unlimited Reprinting Rights. 

 PLUS Intranet Versions. 

 Educational Discounts. 
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